忍者ブログ

NOROMA CLUB -日記-

2017年10月07日  OS再インストールとMcAfee不安定

昨日、SSDを入れ替えて、クローニングですんなり移行できたのですが、
3連休で時間もあったので、結局OS再インストールからやりなおしてみました(笑)

Windowsを再インストールして、
そのあと必要なアプリをインストールしていっても、Program Filesの下がやけにスッキリ。
さすがに5年間も再インストールしていないと、使っていない残骸がいろいろ積み重なっていたようです。

結局、1日掛からず必要そうな設定は再構築できて、
最後にセキュリティソフト入れるの忘れていたので、J:COMのおまけで使えるMcAfeeを入れてみたところ、
PCが急激に重くなる現象が発生・・・。

McAfeeをアンインストールしてみたら元に戻ったので、明らかになにかが起きている模様・・・。
再インストールするまではなんともなかったんですけどね。

ちなみに、McAfeeはコントロールパネルからだとうまくアンインストールできなくて、
専用削除ツールが必要という謎の仕様だそうです。
この時点で、アンインストールするのにもちょっとハマってしまいました。

何度かMcAfeeのインストールとアンインストールを試してみましたが、特に改善する気配もなく。
タスクマネージャで見ると、McAPExe.exe(McAfee Access Protection)の負荷が大きいようなのですが、
このタスクは保護が厳しく設定されているのか、なぜかサービスを停止されることもできず。

手詰まりっぽかったので、McAfeeとは決別して、avast!の無料版に乗り換え。
今のところ快適です。

拍手[0回]

PR

2017年10月06日  Intel SSD 545s

2ヶ月ほど前からPCのプチフリがひどくなってきて、
しばらく様子見してましたが治まる気配もないので、Amazonで新しいSSDを注文。
Intel SSD 545sの256GBです。


ちなみに今まで使っていたのは、Intel SSD 330の120GB。
別にIntel信者ってわけでもないんですが(笑)
さすがにNANDフラッシュを5年間も使い続けたらもう寿命ですかね。

OSも5年間再インストールしていないので、
これを機会にまっさらからやり直そうかとも思いましたが、
考えただけでもめんどくさいです・・・(笑)

というわけで、EaseUS Todo Backupでクローニングしてみたら、
30分ぐらいで終わって、今までどおり普通に起動できました。
便利な時代ですねえ・・・(笑)

拍手[0回]


2017年05月01日  古いPC大整理

家の中で放置されていた古いPCを処分しようかと思ったら、なんかいろいろ出てきました。

まずは無難なところでPanasonic CF-T2。
5年ぐらい前に、中古で\10000だった気がします。
久しぶりに電源入れたら、HDDが死んでたみたいでBIOSしか起動せず。

こっちはPanasonic CF-R2。
10年ぐらい前に、中古で\30000だったような。
小さくて旅行の時に便利でしたが、いつしか使わなくなってLinuxに入れ替えてました。

DELLのPC(型番忘れた)。
なんかデカイし、重いし。
Windows2000だった気がするのですが、ACアダプタが行方不明で起動できず。

FUJITSUのPC(型番忘れた)。
Windows95だった気がするのですが、ACアダプタは繋いでも起動できず。
これもデカイし、重いし。

最後に大ボス、PC-9821Nd。
1994年ごろに新品で買って、たしか\30万ぐらいしたような・・・。
カラー液晶(といっても256色しか出ない)が徐々に普及し始めた頃。

電源を入れたら、意外と起動しました。
「ピポッ」っていうPC98の起動音が懐かしい(笑)
ちなみにHDDが340MBで、メモリが16MBです(当時の標準スペック)。

Windows95もすんなり立ち上がってきた・・・。
ちなみに、OSもMS-DOS6.2→Windows3.1→Windows95と入れ替えたような。

とりあえず立ち上がったものの、
コンパネとかも意外と使い勝手が違っていて、もうよくわからない・・・。


ちなみに、PC98に刺さっていた入っていたHDDとカード類。
USBなんて無いので、外付けドライブはSCSIで拡張するのが一般的な時代。
サウンドカードも別売り(これだけで\1~2万ぐらいはしたような)。

おまけ、XP時代に使っていたマザーボードも出てきました。
Pentium Dかな?
なんか、発熱が凄かった印象しかない・・・(笑)

拍手[0回]


2017年04月23日  ギガビットスイッチングハブ

部屋のスイッチングハブをギガビット対応に変更してみました。
というか、ギガビットだと\10000ぐらいするのかと思ってたけど、
\3000ぐらいなんですね・・・、完全に衝動買いです(笑)

とりあえずベンチマークしてみました。
http://www.musen-lan.com/speed/
 100Mbpsハブ Down63.56Mbps、Up9.43Mbps
 1000Mbpsハブ:Down145.90Mbps、Up9.11Mbps

https://fast.com/ja/
 100Mbpsハブ:Down72Mbps
 1000Mbpsハブ:Down130Mbps

http://www.speedtest.net/
 100Mbpsハブ:Down92.82Mbps、Up9.50Mbps
 1000Mbpsハブ:Down133.29Mbps、Up9.75Mbps

意外と変わるもんですねえ・・・。
ちなみに上りがあんまり変わらないのはJ:COMの仕様。
ベストエフォートでも、下り320Mbpsに対して、上りは10Mbpsしかでないらしい。。。

拍手[0回]


2017年04月16日  MeMo Pad Smart ME301T

イオシスで安かったので買ってみました。
ASUS MeMO Pad Smart ME301T 未開封の新古品で\9980。
だいぶ型落ちっぽいけど・・・、がっつり使う予定もないのでたぶん関係ないような。
というか、使い道はまだ考えてません(笑)

10.1インチなのでだいぶデカイです。
ちなみにスマホ(P8Lite)と比べるとこんな感じ。
解像度はたいして変わらないみたいだけど・・・。

拍手[0回]


2017年03月04日  J:COM乗り換え、その後

先週末に、インターネット環境をJ:COMに乗り換えてから、その後の状況。
開通当日の夜ぐらいから、なんか調子が悪いような・・・。
1時間に1回ぐらいのペースで回線が切れてしまって、ひどいときには10分以上復旧せず。
繋がっているときも、なんか通信が遅いし。。。

J:COMから提供されたルータ兼モデムは HUMAX HG100R-02JG。
管理ツールでログを確認してみると、Criticalなエラーメッセージが大量に出てました。

Critical (3) Received Response to Broadcast Maintenance Request,
But no Unicast Maintenance opportunities received - T4 time out;
CM-MAC=94:09:37:xx:xx:xx;CMTS-MAC=00:17:10:xx:xx:xx;CM-QOS=1.1;CM-VER=3.0;

Critical (3) Started Unicast Maintenance Ranging - No Response received - T3 time-out;
CM-MAC=94:09:37:xx:xx:xx;CMTS-MAC=00:17:10:xx:xx:xx;CM-QOS=1.1;CM-VER=3.0;

MACアドレス的に、どうもモデムから上流側の接続が切れている模様。
翌日にも状況が改善しなかったので問い合わせしてみたら、点検・調整しにきてくれました。
その後は、数日経っても切断されることも無く、速度も安定してそうなので、ひとまず大丈夫かな。。。

拍手[0回]


2017年02月25日  フレッツ光からJ:COMに乗り換え

マンションの設備の都合とか諸々の理由で、
フレッツ光からJ:COMに乗り換えることになりました。

100Mbpsから320Mbpsになったみたいですが、
今のところ体感的にはなにも変わらない感じ。
そもそも家の中の機器がギガビットに対応してないので、
とりあえず改悪してなければ十分です(笑)

ルータも変わってしまったので、家の中のネットワークを再構築。
ちなみにPCが3台と、ラズパイが2台と、DIGAが2台。
あとは、なぜか無線LANルータが3台になってしまって(笑)、ハブも1台。

特にラズパイは固定IPで使っているので、新しいルータでIP割り当て設定して、
外部からアクセスできるようにポート開放の設定して。
なんか、新しいルータのIP割り当てが不安定な気がするけど大丈夫かなあ・・・。
さらにIPアドレスが変わってしまったら、nfsやらtelnetやらftpも繋がらなくなって、設定しなおして・・・。
けっこうたいへん。

拍手[1回]


2016年11月20日  Raspberry Pi 設定あれこれ(MPD編)

Music Player Daemonです。
音はRaspberry Piから出てきますが、操作はWindowsPCやスマホからできるようになります。


・インストール
% sudo apt-get install mpd mpc

・起動
% sudo service mpd start

・各種設定
/etc/mpd.conf
の下記のコメントを外す。
auto_update    "yes"
mixer_type      "software"              # optional

auto_update → データファイルを置いたときに自動的にリストが更新されるようにする。
mixer_type → ソフト側で制御できるようにしておく。

・データディレクトリをリンク
% cd /var/lib/mpd/music
% sudo ln -s /mnt/hdd1/mp3/ .

基本的に音楽データは /var/lib/mpd/music の下に置きます。
直接置くか、リンクするかはどちらでも良いです。

・再起動
% sudo service mpd start

無事、MPDサーバが起動できたら、WindowsのGMPC(Gnome Music Player Client)や、
AndroidのDoroidMPDあたり接続して、リモート制御することができます。

・USB-DACの設定
RaspberryPiの内蔵音源は音が悪いので、外付けのUSB-DACを使いたいところですが、
USBに挿しただけでは使えません。
% cat /proc/asound/cards
で、USB-DACが認識されていることと、優先度が低いこと(内蔵音源の方が高いこと)を確認

USB-DACを優先させるために、設定を変更します。
方法はいろいろあるようですが、内蔵音源が不要であれば殺してしまったほうが早そうです。

/boot/config.txt
の下記の部分をコメントアウト
# Enable audio (loads snd_bcm2835)
#dtparam=audio=on

ちなみに、ネットで検索してみたところ、
/etc/asound.conf を修正する方法や、
/usr/share/alsa/alsa.conf を修正する方法や、
/etc/modprobe.d/alsa-base.conf を修正する方法
が見つかりましたが、どれもうまくいきませんでした・・・。
(やり方がまずかったのかもしれませんが)

ということで、一番確実な内蔵音源を殺すという方法で対処しています。

一度リブートしてみて、USB-DACが認識されていて音が出てくれば、設定完了です。

拍手[0回]


2016年11月19日  Raspberry Pi 設定あれこれ(NFS編)

Raspberry Pi1とPi3の2台を使って、外付けHDDをNFSで共有してみました。


サーバ側の設定

・インストール
% sudo apt-get install nfs-kernel-server

% sudo vi /etc/exports
に下記の内容を追加
/mnt/hdd1/    192.168.24.0/255.255.255.0(rw,sync,no_root_squash)
  ※クライアント側のIPアドレスが192.168.24.0-255の場合の例
  255.255.255.0はサブネットマスク

・起動
% sudo /etc/init.d/rpcbind restart
% sudo /etc/init.d/nfs-kernel-server restart

・確認
% showmount -e
Export list for raspberrypi3:
/mnt/hdd1 192.168.24.0/255.255.255.0
みたいなログが出てきていれば、設定できているはずです。

クライアント側

・インストール
% sudo apt-get install nfs-common
% sudo apt-get install autofs

・確認
% sudo showmount -e <サーバ側のIPアドレス>
Export list for <サーバ側のIPアドレス>:
/mnt/hdd1 192.168.24.0/255.255.255.0
みたいなログが出てきていれば、サーバが参照できるようになっています。

・手動マウントする場合
% mkdir /mnt/hdd1
% sudo mount <サーバ側のIPアドレス>:<サーバ側のディレクトリ> <クライアント側のディレクトリ>
(例) % sudo mount 192.168.24.93:/mnt/hdd1 /mnt/hdd1

・自動マウントする場合
/etc/fstab
<サーバ側のIPアドレス>:<サーバ側のディレクトリ> <クライアント側のディレクトリ> nfs defaults 0 0
(例)
192.168.24.93:/mnt/hdd1 /mnt/hdd1 nfs defaults 0 0
を追加して再起動

拍手[0回]


2016年11月13日  Raspberry Pi3で遊んでみた

土日で、しばらく放置していたRaspberry Pi3で遊んでみました。

とりあえずAndroidのイメージを拾ってきて試してみました。
Android7.0は起動せず(遅すぎて待ちきれなかっただけかもしれませんが)。
Android6.0は無事起動しましたが、かなり遅い。
Cortex-A53の4コアだから、ロースペックなスマホとたいして変わらないはずなんですが。。。

ちなみに、ポケモンは対応していないけど、パズドラなら対応しているみたいです。
とはいえ、GooglePlayがまともに動かなくて全然インストールできませんでしたが(笑)
どっちみち使い道なさそうなので、まあいいけど。

続いてWindows 10。
と思っていたのですが、Raspberry Piで使えるのは「Windows 10 IoT Core」というもので、
普段イメージしているWindows 10とは全然別のものなのだとか。
ややこしそうなので、インストールするまでもなくやめました。

結局、無難にRaspbianで使うのが一番良さそうです。
ということで、現在Raspberry Pi1で運用しているサーバを置き換えてしまおうかと思い、
まっさらな状態からインストール&各種設定中。
この前Pi1の方もインストールしなおしたところだし、ちゃんとメモも残してましたので、
今回はインストールも捗ります。
あと、さすがにPi1とPi3では性能が違いすぎて、サクサク感がだいぶ快適(笑)

拍手[0回]